Gas Gauge Not Working

Interior and Electrical

  1. bkulibert

    bkulibert Active Member

    Messages:
    25
    Likes Received:
    2
    Joined:
    Nov 11, 2017
    Location:
    Mayville, WI 53050
    I have a '89 Gran Fury AHB and my gas gauge is not working. I have tried two other gauges and they don't read as well. The fuel tank sending unit is brand new as well. Any suggestions.
     
  2. Oldiron440

    Oldiron440 Well-Known Member

    Messages:
    958
    Likes Received:
    187
    Joined:
    Apr 25, 2017
    Location:
    Iowa
    Just because your sender is new don't make the assumption that it's good.
     
  3. 80mirada

    80mirada Well-Known Member

    Messages:
    804
    Likes Received:
    217
    Joined:
    Sep 3, 2012
    Location:
    Wisconsin, West Bend depends
    You could have a bad sender even being new. That said you could have damaged wiring somewhere
     
    Oldiron440 likes this.
  4. volare 77

    volare 77 Well-Known Member

    Messages:
    610
    Likes Received:
    59
    Joined:
    Jun 12, 2014
    Location:
    maryland
    Did you test the sending unit before install? It should measure from around 10 ohms to 73 ohms for a OEM sending unit. The aftermarket sending unit many times are much less accurate but you should at make sure it works before install because sometimes you can bend the tabs to make some adjustment. Go on youtube on how to test. The wire at the sending unit can be momentarily grounded to see if the dash gauge moves to full. If it doesn`t the dash gauge, limiter or wiring could be the issue. My car has a ground strap on the fuel line where the rubber hose connects the sending unit and the metal fuel line.
     
    Last edited: Aug 20, 2018
  5. lowbudget

    lowbudget Well-Known Member

    Messages:
    494
    Likes Received:
    88
    Joined:
    Feb 27, 2011
    Location:
    Vernal Utah
    Ground strap or gauge voltage limiter? I'd check the ground first.
     
  6. 78VOLAREWAG

    78VOLAREWAG Well-Known Member

    Messages:
    54
    Likes Received:
    8
    Joined:
    Nov 3, 2017
    Location:
    PITTSBURGH PA
    I put a new pump/sending unit in my 97 Ram. Sending unit stopped two weeks later. Good thing I have a trip odometer, because I'm not dropping that tank while the pump works fine.