The Rescue of a 1984 Plymouth Fury

Projects & Restorations

  1. DCAspen

    DCAspen Well-Known Member

    Messages:
    991
    Likes Received:
    198
    Joined:
    Sep 27, 2011
    Location:
    ct.
    I have an older washer bottle NOS minus the fluid level indicator if your interested.
     
  2. Coronet 14

    Coronet 14 Well-Known Member

    Messages:
    46
    Likes Received:
    4
    Joined:
    Feb 12, 2019
    Location:
    Hudson FL
    The washer bottle was there when I got the car. Half the wiper linkage is missing though.
     
  3. XfbodyX

    XfbodyX Well-Known Member

    Messages:
    511
    Likes Received:
    99
    Joined:
    Sep 9, 2015
    My pn shows the one I posted of is 83 up so id bet you have a idiot light for wiper fluid level.
     
  4. Aspen500

    Aspen500 Well-Known Member

    Messages:
    4,025
    Likes Received:
    1139
    Joined:
    Feb 14, 2015
    Location:
    Rib Mountain (Wausau) WI
    That's is what the plug is for, a low washer fluid light. My '96 Dakota has one with the same brown connector and even the same color wires, plugged into the level sensor. It's possible your car may or may not have the light. They used the same harness in many trim levels and options so, it may have never been plugged into anything.
     
  5. Ele115

    Ele115 Well-Known Member

    Messages:
    114
    Likes Received:
    29
    Joined:
    Apr 24, 2019
    Location:
    Tampa FL
    There's an 85 Gran Fury in Debary, Fl looking for a home. I may take the trailer and go see it. I appreciate you for saving this one
     
  6. Ele115

    Ele115 Well-Known Member

    Messages:
    114
    Likes Received:
    29
    Joined:
    Apr 24, 2019
    Location:
    Tampa FL
    Was that an ex-Hillsborough School District car?
     
  7. MoparDan

    MoparDan Well-Known Member

    Messages:
    156
    Likes Received:
    16
    Joined:
    Mar 17, 2011
    Location:
    Daytona Beach, FL
    I think they all have that plug, mines got the plug, but doesn't have the light, in fact mine's a factory no-a/c car, but still has all the plugs for the a/c stuff so they probably used one harness. I think these cars only have the low washer fluid light if they have the extra warning lights on the gauges
     
  8. Aspen500

    Aspen500 Well-Known Member

    Messages:
    4,025
    Likes Received:
    1139
    Joined:
    Feb 14, 2015
    Location:
    Rib Mountain (Wausau) WI
    I remember when I worked as a dealer service tech, people would come in saying something is missing, or came unplugged and point to a loose connector. Even after explaining it was for something their particular car didn't have, I think a few didn't understand when you tell them for example, "that's for the cruise control servo and your car doesn't have cruise" or "that's the connector for the A/C clutch, that one's for the low pressure switch but your car doesn't have A/C". No cruise or A/C, shows you how long ago that was, lol.